Configuración de Link Aggregation en Modo Manual con switches conectados directamente

Overview

Link Aggregation incrementa el ancho de banda uniendo varios enlaces físicos en un único enlace lógico. Link Aggregation puede funcionar en modo manual o Link Aggregation Control Protocol (LACP).
En modo manual vamos a tener que crear un Eth-Trunk y agregar interfaces miembros al Eth-Trunk. En este modo, LACP no es requerido. Si se requiere un ancho de banda alto entre dos dispositivos conectados directamente pero el dispositivo remoto no soporta LACP, podemos utilizar el modo manual. El modo manual puede incrementar el ancho de banda, mejorar la confiabilidad e implementar balanceo de carga.
En el modo manual,todos los enlaces forwardean datos y balancean la carga de tráfico.

Notas de la configuración
  • Las interfaces miembro de un Eth-Trunk deben usar el mismo tipo Ethernet
  • Ambos dispositivos del Eth-Trunk deben usar la misma cantidad de interfaces físicas, tasa de interface, modo duplex y modo de control de flujo
  • Si una interface del dispositivo local es añadido a un Eth-Trunk, se debe agregar tambié una interface del equipo remoto conectada directamente a la interface del equipo local
  • Ambos dispositivos deben usar el mismo modo Link Aggregation
  • Este ejemplo aplica a todas las versiones y productos
  • Este ejemplo aplica a todas las versiones de todos los switches de la serie S
Requisitos de la red

bla bla bla

Procedimiento
    1. Crear un Eth-Trunk en el SwitchA y SwitchB y añadir interfaces miembros
      system-view
      [HUAWEI] sysname SwitchA
      [SwitchA] interface eth-trunk 1
      //Creamos Eth-Trunk 1.
      [SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/1 to 1/0/3 //Le añadimos GE1/0/1, GE1/0/2, and GE1/0/3 to Eth-Trunk 1.
      [SwitchA-Eth-Trunk1] quit

      Repetimos los mismos pasos para el switch B.
    2. Crear VLANs y añadir interfaces
      • Crear VLAN 10 y VLAN 20 y añadir interfaces.
        [SwitchA] vlan batch 10 20
        [SwitchA] interface gigabitethernet 1/0/4
        [SwitchA-GigabitEthernet1/0/4] port link-type trunk
        //Configuramos la interface como trunk. El tipo de link por defecto es No Trunk.
        [SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
        [SwitchA-GigabitEthernet1/0/4] quit
        [SwitchA] interface gigabitethernet 1/0/5
        [SwitchA-GigabitEthernet1/0/5] port link-type trunk
        //Configuramos la interface como trunk. El tipo de link por defecto es No Trunk.
        [SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
        [SwitchA-GigabitEthernet1/0/5] quit

        Repetimos los mismos pasos en el SwitchB.
      • Configurar Eth-Trunk1 para permitir que pasen los paquetes desde VLAN10 y VLAN20
        [SwitchA] interface eth-trunk 1
        [SwitchA-Eth-Trunk1] port link-type trunk
        //Configuramos la interface como trunk. El tipo de link por defecto es No Trunk.
        [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
        [SwitchA-Eth-Trunk1] quit

        Repetimos los mismo pasos en el SwitchB.
    3. Establecer el modo de balanceo de carga en Eth-Trunk1.
      [SwitchA] interface eth-trunk 1
      [SwitchA-Eth-Trunk1] load-balance src-dst-mac
      //Configuramos el balanceo de carga basado en las direccions MAC de origen y destino en Eth-Trunk 1.
      [SwitchA-Eth-Trunk1] quit

      Repetimos los mismos pasos en el SwitchB.
    4. Verificar la configuración.
      Corremos el commando display eth-trunk 1 en cualquier vista para verificar si fue creado el Eth-Trunk y si las interfaces fueron añadidas.
      [SwitchA] display eth-trunk 1
      Eth-Trunk1's state information is:
      WorkingMode: NORMAL Hash arithmetic: According to SA-XOR-DA
      Least Active-linknumber: 1 Max Bandwidth-affected-linknumber: 8
      Operate status: up Number Of Up Port In Trunk: 3
      --------------------------------------------------------------------------------
      PortName Status Weight
      GigabitEthernet1/0/1 Up 1
      GigabitEthernet1/0/2 Up 1
      GigabitEthernet1/0/3 Up 1

      La información presentada muestra que Eth-Trunk1 contiene tres interfaces miembro: GigabitEthernet1/0/1, GigabitEthernet1/0/2 y GigabitEthernet1/0/3. El status de las interfaces miembro es Up y el valor de Operate Status es también Up